The "can't reply to threads" downtime - an explanation.

Discussion in 'NoFap Technical Support and Feedback' started by Alexander, Jan 19, 2017.

  1. Alexander

    Alexander Website Admin
    Staff Member

    Summary: An update of the anti-DDOS protection broke the website. We figured it out and the website now works.

    Hello Fapstronauts,

    Something happened that caused a widespread outage for posting functionality on NoFap. It happened around 10:15 pm Eastern last night and lasted until about 12:30 pm today, totaling about 14.25 hours of reply downtime.
    • Many people were having trouble REPLYING to existing threads.
    • Trouble POSTING new threads. The "topic" field appeared but not the "content" field.
    • The live chat box vanished.
    I tried many different approaches, including overwriting the server files with backups, updating the software versions, etc. I tried to edit the CSS to force the reply field to appear, which worked, but resulted in even more problems.

    Today, together with Martin and Jack, the three of us collaborated in various ways to figure out the root cause of the problem - Cloudflare, the software that protects NoFap from DDOS attacks.

    Cloudflare changed something on their end that broke NoFap. We disabled the particular script that is causing this interference and we're going to work with Cloudflare to figure out exactly what happened.

    Thank you for bearing with us through these technical difficulties. When stuff like this happens, we do everything in our power to resolve the issue as quickly as possible because we know how important NoFap is for people to stick to their sexual health goals. As time moves forward, we'll continue to work to reduce downtime and improve the usability of the platform.

    Thank you to the moderation team. Thank you to Martin and Jack for your assistance in diagnosing the problem. And thank you to the community for sticking with us through these issues.




    Seeking Feedback:

    To those impacted using Firefox, Chrome, and other major browsers, please confirm if the problem with replying to threads has been resolved for you. If you have a problem replying to posts, please contact us to let us know and include which browser you are using.
     
    spitfire, SMK, Low and 2 others like this.
  2. TheLoneDanger

    TheLoneDanger Fapstronaut

    I'm on Chrome and was having that problem earlier today. But now I'm able to post and reply.
     
  3. Alexander

    Alexander Website Admin
    Staff Member

    Great to hear, thank you for the reply.
     
  4. FredJim

    FredJim Fapstronaut

    21
    18
    3
    think I'm good now thanks.
     
    Aexander likes this.
  5. Sven Pellegrain

    Sven Pellegrain Fapstronaut

    130
    131
    43
    I use Firefox, was unable few hour ago, but, obviously, I can do now. :)
     
    Aexander likes this.
  6. Thomas More

    Thomas More Fapstronaut

    85
    98
    18
    Yip, everything ok my side...
     
    Aexander likes this.
  7. Headspace

    Headspace Fapstronaut

    1,228
    2,031
    143
    I'm experiencing the same thing.
     
  8. Shin Iu

    Shin Iu Fapstronaut

    Had problem in the morning, but now works
     
  9. SnowWhite

    SnowWhite Fapstronaut

    1,402
    1,270
    143
    Replying and creating threads works again.

    Just BTW, similar issues appeared already sometimes in the past, but only after the first try after a login. From the second try on, it worked.
     
  10. SnowWhite

    SnowWhite Fapstronaut

    1,402
    1,270
    143
    @alexander this thread is now appearing on the right bottom side of the screen in an overlay box, which cannot be clicked away!

    [​IMG]
     
  11. I use chrome. I think i had this problem earlier but now it seems to work.
     
  12. IWantToBeAHuman

    IWantToBeAHuman Fapstronaut

    112
    28
    28
    I'm using chrome and it's working just fine
     
  13. yeah that is a little bit annoying
     
  14. Alexander

    Alexander Website Admin
    Staff Member

    Adding a "dismiss" button now.
     
    SnowWhite likes this.
  15. SnowWhite

    SnowWhite Fapstronaut

    1,402
    1,270
    143
    Thanks, works ;)
     
  16. Alright thanks :D
     
  17. Alexander

    Alexander Website Admin
    Staff Member

    Keeping an eye on this thread. I had some logout issues too and wondering if Cloudflare is to blame for everything.
     
  18. BuddhaPunkRobotMonk

    BuddhaPunkRobotMonk Community Manager
    Staff Member

    2,193
    6,341
    143
    Working on Chrome. I actually had a bit of fun trying to find a browser that would work on a linux os. I found an obscure one- Arora- that did the job.
     
  19. NMIE

    NMIE Fapstronaut

    133
    95
    28
    Im firefox user and problem seems to be fixed now, thank you :)
     

Share This Page