Post published by Brown Boy

After 138 days of No PMO hardmode, I relapsed.
To cure My PIED(i hope its PIED not ED) and autogynephilia I started this. yesterday i tried to hv sex with my new GF for the first time. when we were together, I was so excited and aroused but down there, nothing not even a little bit of erection. After 20-25 min she tried to get it up with her hands nd i ejaculated like in 10 seconds. i told her that i haven't touched it for almost 4 months nd she said "its ok" and then we tried again after 20 mins but no erection. she said its ok we'll try next time. i was so so so so so embarrassed. After she left i wanted to release this sexual energy so I masturbated and again ejaculated so soon with no erection and then again 2 times more and 4 times today.
and in all these ejaculations quantity of semen was not so much as i expected and my semen was yellow now its back to white.
i dont even know how to feel.
i know i can go on for longer streak but whats the point. there was no improvement in ED or autogynephilia, been flatline more than 100 days
:emoji_cold_sweat::emoji_confounded::emoji_confounded::emoji_confounded::emoji_tired_face::emoji_tired_face::emoji_tired_face::emoji_tired_face:
SLAA1 more_vert
SLAA1
It’s possible - very possible - that you didn’t give the reboot enough time.
Brown Boy more_vert
Brown Boy
probably but tht incident with my gf made me lost control.
Vitoriosa likes this.
Maninsearchofasoul more_vert
Maninsearchofasoul
How long have you had problems with autogynephilia?
Brown Boy likes this.